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Summary 
FlexMax is: 

a drawing tool for body postures 

an assembly tool for sequences of body postures 

a database tool for storing and retrieving body postures and sequences thereof 

a sample database with postures and sequences from Hatha-Yoga 

The drawing tool starts with a complete body. To draw a specific posture you only change the posi-
tions of various body parts. With copy and paste you can use the results of your work in your docu-
ments (e.g. Microsoft Word). And you can store them in the database for later use. 

The assembly tool enables you to assemble several postures to a sequence and to link them with 
breathing instructions. Again, you can use those sequences in your documents and store them in the 
database. 

The database tool is used to store and retrieve postures and sequences of postures. For easy access  
you can give them a name and other attributes. The set of attributes can be tailored to your needs. 
Either you use the sample database and add your own objects to it, or you create your own database. 

The sample database contains a set of predefined postures and sequences from Hatha Yoga. You 
can either use them directly in your documents, or you can modify and then use them. 

Installing and Starting FlexMax 
If you possess a FlexMax CD, insert it into the CD drive of your computer, and wait a few seconds. 
The installation procedure will start automatically. 

If you have downloaded FlexMax, start flexsetup.exe from the location where you saved the 
download. 

Follow the instructions of the setup dialogue. 

The setup program adds a FlexMax group to your Start menu, containing these entries: 

FlexMax. Select this entry to start the drawing tool. 

Database. By selecting this entry you start the database tool. 

Help. Select this entry to view the online help for FlexMax. 

In case you don t have a FlexMax license yet, you may use the program for an evaluation period of 60 
days. This information will appear in a dialogue window whenever you start FlexMax. Click on Start 
FlexMax in this dialogue window.  

When you buy FlexMax, you receive a 10 digit license key. If you buy FlexMax by download, the li-
cense key will be sent to you by E-Mail. If you buy FlexMax on CD, you will find the license key either 
at the back cover page of the booklet in the CD jewelcase, or inside the CD in the file keyinfo.txt.  
Click on Enter License Key in the startup dialogue, then write the license key into the text field of the 
window showing up and close the window by clicking on the OK button. From now on the startup dia-
logue will not appear any more, and FlexMax will run without a time limit. 

If you have not entered a license key after 60 days, FlexMax will stop running.  
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The Drawing Tool 

Summary 

 

To start the drawing tool from the Windows Start Menu select Applications 

 

FlexMax 

 

FlexMax. 

The left part of the window shows a stylized body in the default posture. You can select the body parts 
to modify them. Change the direction of the selected body part by dragging the small circle ( handle ) 
at the end of the body part, or by turning the mouse wheel. To turn the body as a whole, turn the back. 

In the right part of the window you can change properties. Which properties are offered for modifica-
tion depends on the body part selected.  

If you click into the background of the drawing area, controls for zooming the image and for setting its 
export size appear on the upper right side of the window. The Export View in the bottom right part 
shows what the image will look like in your document. Here, with one mouse click, you can put the 
image into the Windows clipboard from where you can paste it into your document.  

Use the commands in the Posture menu to store your image in the database or to fetch one from the 
database.  

Use the commands in the Edit menu to copy parts or all of your image into the clipboard, or to paste a 
FlexMax image from the clipboard into your image. 

The Add menu holds more objects you can use to enrich your image. You can move or change any 
object by mouse dragging. 
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Editing a Posture 

Modifying Body Parts Directly With the Mouse 

 

If you select the back, you can change the direction of the whole figure. Make sure the Turn Legs 
Also switch is on, point the mouse cursor to the handle at the top of the back, press the left mouse 
button and keep it pressed, then move (or drag ) the mouse. The whole figure will turn round, follow-
ing the movements of the mouse cursor. 

Select some other body part to change its position in the same way: Point to the handle at the end of 
the selected part, press the left mouse button, keep it pressed, and move the mouse. 

If your mouse has a mouse wheel, there is another way to turn a body part: Select it, then turn the 
mouse wheel. 

The form of the mouse cursor indicates in what kind of area the cursor is. Usually the cursor is an 
arrow pointing upwards to the left  . If the cursor touches a body part, it changes to a hand  indicat-
ing that you can select this part here. If it touches the main area of a selected part it, changes to a 
cross  indicating that you can move the whole body by dragging here. If the cursor touches the han-
dle of a selected part, it becomes an upward pointing arrow  indicating that you can turn the selected 
part by dragging here. 
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For each body part not only the direction can be changed, but also its length. In addition, the back 
can be bended, and knees and elbows can be rounded. These and other properties are set in the 
lower right part of the window.  

Setting Properties for the Whole Figure  

Select some body part. In the right part of the window, a frame labeled Figure is shown. 

In the left part of this frame you can set the Line Width and Grey Scale for the whole figure. To do 
this, drag the control or enter the desired values into the text fields on top of the control. Line Width 
can be from 1 to 5 Pixels, Grey Scale can be between 10 and 100 %.  

The button Figure  in the bottom left corner of the Figure frame opens a menu with commands for 
the whole figure. 

 

Flip Vertical: Flip the whole figure around its vertical axis. 

Set all body parts to Length 100%: This can be useful in case you have lengthened or 
shortened individual body parts. 

To Front: Places the figure in front of any other objects in the image. 

To Back: Places the figure behind any other objects in the image. 

Hint: In order to place individual body parts before or behind the head, use the To Back check box in the frame for the body 
part in question. 

Use This as Template for New Objects: After you have selected this command, the current 
image will be used whenever FlexMax starts, or when you select New from the Posture 
menu, or when you select Figure from the Add menu. 

Use Default Template: After you have selected this command, the original default will be 
used in the instances mentioned above. 

Setting Properties for Body Parts 

In the right half of the Figure frame you find a list of all body parts. The selection in this list corre-
sponds to the selection in the image itself. So you can also select a body part by clicking into this list 
and, if necessary, on the Left or Right button below the list. This way of selecting can be useful if 
direct selection in the image is difficult or if body parts are hidden. 

Below the Figure frame there is another frame labeled after the body part selected. Using the switches 
and controls in this frame you can set the properties of the selected part. Controls can be either ma-
nipulated directly with the mouse or by entering a numeric value into the associated text box. The 
property Direction can also be set by direct manipulation of the body part (cf.  Modifying Body Parts 
Directly With the Mouse). 
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Properties of an Individual Body Part 

Direction: Direction of the body part, relative to the part to which it is appended, measured in 
minutes on the clock face. E.g., direction 15 for the forearm means a 900 angle between the 
forearm and the upper arm. The direction of the back is meant in absolute terms. 

Moving a body part implies moving all the parts appended to it. 

Turn Legs Also: If this check box in the Back frame is activated, not only head and arms 
move together with the back but also the legs. Thus, by turning the back you turn the whole 
body. 

Length: The length of a body part is measured in per cent of the default length. How to chan-
ge the default lengths, cf. Body Proportions. 

Hide: Use this check box to make the selected body part invisible. 

To Back: If this check box is on, the selected part is drawn behind the head, in case they 
overlap. 

Bending the Back 

Bend the back using the Bending and Bias controls, which are shown in the Back frame. 

The Bending control determines the extent of the bending. Values can be between -100 and 
100.  

With the Bias control you can shift the bending to the upper or lower back. Values can be be-
tween -100 and 100. Positive values indicate that the bending is more in the upper back, 
negative values indicate that the bending is more in the lower back. 

Rounding Knees or Elbows 

Knees and elbows can be rounded. The rounding of a knee is a property of the lower leg, the rounding 
of an elbow is a property of the forearm. The controls allow values between 0 and 25. The numeric 
value indicates the rounding radius, measured in per cent of the length of the upper leg or upper arm 
respectively. 

The Head 

For the head, the Bias control determines how oval it is. The numeric value indicates the relation be-
tween height and width of the head in per cent. 

The Nose 

For the nose there are only three possible directions: 15, 0, and -15. 15 means right, -15 means left, 
and 0 means that the nose is represented by a dot in the middle of the face. 

Adding Other Objects 
Within the drawing tool you can add other objects to a figure. The properties of a selected object will 
be offered for editing in the right part of the window . To move an object first click on it, then use the 
mouse to drag it. Some objects have handles to change their size. 

Figure 

You can have two or more bodies in your drawing, e.g. to show partner postures. 

To add another figure, select Figure from the Add menu. 
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If you want the new figure to be a mirror of an existing one, instead of the standard figure, proceed as 
follows: 

Click on the existing figure and select first Copy and then Paste from the Edit menu. Now click on the 
new figure. Then click on the button labeled Figure  in the Figure frame. In the menu that opens, 
select Flip Vertical. 

Text Line 

Using the Text Line object you can add short comments, such as posture names or breathing instruc-
tions. 

Select Text Line from the Add menu. Enter your text into the textbox in the Text Line frame. 

 

The Text Line Frame also lets you choose some font properties. The numeric value for the font size 
indicates the font height, measured in per cent of half the longer side of the drawing area with scaling 
set to 100%. The value range is between 4 and 50. 

Auxiliary Objects: Wall Line, Ground Line, Block 

You can use these auxiliary objects to enrich your image. Select the desired object type from the Add 
menu. Once the object is selected you can change its size by dragging the handles. Use the controls 
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in the properties area to set line width and grey scale. The block can be drawn filled or just as a 
frame. 

 

Controls for the Image as a Whole 
If you click into the background of the image area, the right part of the window offers controls applying 
to the image as a whole. In addition, the export view is shown, that is the view of the image as it will 
appear in your document. And there is a button which allows you to put the image into the Windows 
clipboard from where you can paste it into your document. 

The Zoom 

Setting the Zoom affects the size of the image in the drawing tool. The Zoom control is used only to 
make editing more comfortable. It has no effect on the size of the image as it appears in your docu-
ment or as it is stored in the database. 

Export Size 

Use the Export Size control to define the size of the image as it appears in your document, or in the 
database, or in the assembly tool. The numeric value of the export size measures the length of the 
back in millimeters. The Export view frame shows the image according to the export size set.  

It is possible to change the size of an image after it has been exported to a document, e.g. by drag-
ging one of the resize handles showing up when the image is selected in the document. However, this 
changes all the image s properties, including line width and font size. In contrast, changing the export 
size leaves line width and font size unaltered. 

Managing and Using Posture Images 

Transferring a Posture Image into a Document 

Click into the background of the drawing area to make the settings for the image as a whole visible. 
Then click on the Copy To Clipboard button in the Export View frame. 

Or: 

Select Copy All from the Edit menu.  

Both actions lead to the same result: The entire image is being copied into the Windows clipboard, so 
you can paste it into your document. Please consult the documentation of your word processing appli-
cation for details on how to paste images from the clipboard into the document. 



 

9

 
Hint: FlexMax creates its images in the Enhanced Metafile format. Some word processing applications, however, implicitly 
convert this to the weaker Metafile format, which slightly reduces the quality of head and back display.  

For example, older versions of Microsoft Word (prior to Office XP) do this conversion if you use the Paste command from the 
Edit menu. You can, however, force Word to use the original format by choosing the Paste Contents command and selecting 
Enhanced Metafile in the dialogue window that comes up.   

Storing a Posture Image in the Database 

Select Save As ... in the Posture menu. The following window is displayed. 

 

Into the Name field, enter a name which characterizes the image. 

If your database has an extended scheme of attributes, you can enter values for attributes other than 
the name, which makes it easier for you to find the image later (cf. Editing the Attribute Scheme). 

Click on the Show Database Contents command button if you want to view the database content in 
order to harmonize the new name with existing names. Cf. The Database Tool on how to handle the 
database tool.  

Confirm and close the window by clicking on the OK button. 

Loading a Posture Image from a Database 

Select Open ... from the Posture menu. The following window opens.  

 

Select the posture you want and confirm by clicking on the OK button.  

Or: Double click on the posture image you have selected. 

Cf. Finding Objects in the Database on how to find objects in the database. 

Exporting a Posture Image to a File 

You can store a posture image as a file in the graphics format Enhanced Metafile (.emf). You may 
want to do this in order to send it by e-mail, or to display it on a web page. 

Select Export To File in the Posture menu. In the dialogue window that follows, navigate to a folder, 
and enter a file name. The file name suffix .emf will be appended automatically. 
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Importing a Posture Image from a File 

If you have an Enhanced Metafile created by exporting from FlexMax, you can import it into FlexMax. 
Select Import From File  from the Posture menu; then, in the dialogue that opens, navigate to the 
folder containing the file and select it. 

Fetching a Posture Image from a document 

You can transfer a posture image from your document back to the drawing tool for further editing.  

To do this, copy the image from your document to the clipboard. Please consult the documentation of 
your word processing application for details. 

Now switch to the FlexMax drawing tool and select Paste from the Edit menu (or from the Context 
Menu which you open by using the right mouse button in the drawing area). 

Observe that pasting does not remove the previous image from the drawing area. It may, therefore, be 
a good idea to clear the drawing area in advance. 

Customizing the Tool s Appearance 
You change the size of the drawing tool by dragging an edge or a border of the window. The size of 
the image adapts to the size of the drawing tool.  

To show or hide the properties area, select Properties from the View menu. 

To zoom the image in or out, use the Zoom control. This control is displayed in the properties area, 
after you click into the background of the drawing area (if the View Properties menu entry is switched 
on). This setting has no effect on the size of the image when you transfer it into a document.  

Settings 
To open the settings window, select Settings from the View menu. 

 

Settings for the Drawing Tool 

Export Size for Posture Images 

In this tab you can control the default Export Size, which is assumed whenever FlexMax starts with a 
new image. You can change this setting for each image, and it is being saved along with the image. 
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Hit Tolerance for Mouse Click 

When you click on an object, a hit is detected if the click is within a certain range around the object. 
Here you can increase or decrease this range. 

Use Defaults 

Click on this button to fill the fields in this tab with the manufacturer values. 

Settings for the Figure 

 

Body Proportions 

In this tab you can set the default lengths for the individual body parts. The values entered here are 
used as 100% reference value in the length controls. 

The measuring unit for these values is 1/200 of the longer side of the drawing area in the drawing tool 
with zoom=100%. The absolute size of the body is determined by its export size. 

Use Defaults 

Click on this button to fill the fields in this tab with the producer values. 

Menu Commands 

Posture 

New 

Deletes the current image and creates a new image using the default figure. 

Open ... 

Opens a dialogue window to select a posture image from the current database. To open objects from 
a different database, cf. Changing the Current Database. 

Save 

This entry is active only if the current object has been opened from the database. The command 
overwrites the database object with the current image. 
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Save As ... 

This command opens a dialogue window which allows you to enter attributes (such as name) to be 
stored with the posture image. The image will then be stored in the database as a new object. 

Export To File 

 
This command opens a file browser dialogue allowing you to navigate to a folder and to enter a name 
for the file in which the current posture image shall be stored. The file name suffix .emf for Enhanced 
Metafile is appended automatically. 

Import from File 

 

This command opens a file browser dialogue allowing you to navigate to a folder and to select a file in 
the Enhanced Metafile (.emf) format. If this file has been created by exporting from FlexMax, the 
content will be loaded into the drawing tool. 

Exit 

Closes the drawing tool. 

Edit 

Undo 

Restores the image to the state before the last change. 

Copy All 

Copies the entire image to the Windows clipboard.  

Cut 

Deletes the selected object (Figure, Line, Block, ) from the drawing area and puts it into the Win-
dows clipboard. 

Copy 

Copies the selected objects to the Windows clipboard.  

Paste 

Inserts objects from the Windows clipboard, provided they are Enhanced Metafile images created by 
FlexMax. You can, e.g., copy a FlexMax image from Word into the clipboard and then paste it into 
FlexMax for further editing. 

The Paste command does not clear the drawing area, it just adds an object to what is already there. 

Delete 

Deletes the selected object(s) from the image. Pressing the Del key has the same effect. 

Add 

Figure 

Adds another figure to the image.  

Text Line 

Adds a text line to the image. The text can be entered in the textbox of the Text Line frame. You can 
move the text line by dragging it with the mouse. 

In the Text Line frame you can also set the font properties. 
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Ground Line 

Adds a horizontal line. Use the mouse to move it and to change its size. In the Ground Line frame 
you can set line width and greyscale. 

Wall Line 

Adds a vertical line. Use the mouse to move it and to change its size. In the Wall Line frame you can 
set line width and greyscale. 

Block 

Adds a rectangle. Move it by dragging with the mouse. Change its size by dragging its resize handles. 
In the Block frame you can set line width and greyscale and choose to have it drawn filled. 

View 

Properties 

With this command you can show or hide the properties area in the right part of the window. 

Assembly Tool 

With this command you can show or hide the assembly tool. The assembly tool is displayed in the 
same window below the drawing tool. 

Database 

This command opens the database view.  

Settings 

This command opens the Settings dialogue window. 

Help 

Contents 

This command opens the online help. The online help is viewed with the current Internet Browser. 

About ... 

This command opens a window showing product name and version. 

Context Menu 

To open the context menu click with the right mouse button into the drawing area. The menu contains 
the same commands as the Edit menu. 

Pop-up Menu in the Figure Frame 

For this menu to be displayed, the entry Properties in the View menu must be active. The pop-up 
menu opens when you click on a figure and then click on the button labeled Figure  in the Figure 
frame. 

Flip Vertically 

Flips the whole figure along a vertical axis creating a mirror image. 

Set All Body Parts to Length 100% 

This command simultaneously sets the length of all body parts to 100%. For example, if you have 
changed the default settings for Body Proportions

 

(thus changing the meaning of 100% length for 
certain body parts), you may want to use this command to let those changes take effect for the figure 
your are working on.  
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To Front 

This command brings the selected figure to the front if there are other overlapping objects in the draw-
ing area. 

To Back 

This command brings the selected figure to the back if there are other overlapping objects in the draw-
ing area. 

Use This as Template for New Objects 

Through this command the current figure will be used as a template in the following situations: 

when the drawing tool is started 

when the New command in the Posture menu is selected 

when the Figure command in the Add menu is selected 

Use Default Template 

Through this command the producer s default figure will be used in the cases mentioned above. 

Pop-up Menu in any of the Frames Text Line, Wall Line, Ground Line, Block 

This menu is displayed only if the entry Properties in the View menu is active, and a Text Line, Wall 
Line, Ground Line, or Block object is selected. The pop-up menu opens when you click for example on 
a text line and then click on the button labeled Text Line in the text line frame. Use the same proce-
dure for wall lines, ground lines, and blocks.  

To Front 

This command brings the selected object to the front relative to other overlapping objects in the draw-
ing area. 

To Back 

This command brings the selected object to the back relative to other overlapping objects in the draw-
ing area. 

Use This as Template for New Objects 

Through this command the current object will be used as a template whenever the Text Line, Wall 
Line, Ground Line, or Block command will be selected in the Add menu. 

Use Default Template 

This command has the effect that from now on the producer default object will be used in the cases 
mentioned above. 
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The Assembly Tool 

Summary 

 

To start the assembly tool, first start the drawing tool and then select Assembly Tool from the View 
menu. 

The assembly tool is displayed below the drawing tool. Between the two tools there is a grey line. Drag 
this line with the mouse to change the height of the assembly area. 

The menu bar now contains another menu Sequence with commands similar to those of the Posture 
menu. Using the Sequence menu you can load sequences from the database and save sequences to 
the database.  

The commands in the Edit menu operate on the assembly tool whenever the assembly area is active. 
The active area is indicated by an additional black border line around it.  

The assembly area is a textbox in which you can insert images. Just as in your word processing appli-
cation, you can set the insertion cursor with a mouse click and you can select a text range by dragging 
the mouse over it. To select an image, click on it.  

Hint: For technical reasons, the assembly tool performs a conversion from the Enhanced Metafile format to the weaker Metafile 
format. As a consequence, the display quality for the head and the back is slightly reduced. If this should be unacceptable in 
certain cases, please transfer posture images directly from the drawing tool into your document, without using the assembly 
tool.  

Assembling a Sequence 

Adding a Posture Image 

From the Drawing Tool 

A mouse click in the assembly area sets the insertion point to the place where you want the new im-
age to be placed.  

Click on the Down Arrow  between the drawing area and the assembly area to copy the image 
from the drawing tool into the sequence. 
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From the Databas e 

Select Database  from the View menu. This opens the database in a new window. 

In the database window, use the right mouse button to click on the image wanted and select Copy 
from the context menu. Compare Finding Objects in the Database on how to find an image in the da-
tabase. 

In the assembly tool, set the insertion point to the place where you want the posture to be. Use the 
right mouse button to click in the assembly area and select Paste from the context menu. 

From a  Document 

In your document, copy the posture image into the clipboard. Consult the documentation of your word 
processing application for details. 

In the assembly tool, set the insertion point to the place where you want the posture to be. Right-click 
and select Paste from the context menu. 

Changing a Posture Image 

Editing a Posture Image 

In the assembly tool, select the posture image and click on the Up Arrow . This copies the image 
into the drawing tool. If there was an unsaved image in the drawing tool, you will be given an option to 
save it first. 

After you have made the changes to the posture image, select the old posture image in the assembly 

tool and click on the Down arrow . The old posture will then be replaced by the new one. 

Rescaling a Posture Im age 

You may want to change the export size of an individual posture image in order to harmonize the se-
quence. Click on the posture image you want to rescale, and select Rescale  from the Edit  menu or 
from the right-click context menu. A dialogue window allows you to enter the desired size. The export 
size which has been used for the image so far is displayed here for reference. For the interpretation of 
the numeric value cf. Export Size. 


